Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Aller à la page:  1 2 Page suivante
Page: 1 sur 2
Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Bonjour,

Après migration de 8.10 à 9.04 ne pouvant plus obtenir une résolution convenable (1920x1080) pour mon écran , après plusieurs essais de modif de xorg.conf, j'ai réinstallé manuellement le pilote NVidia 180.51 comme indiqué [doc.ubuntu-fr.org]

Après compilation du pilote en mode console et redémarrage, l'interface graphique n'arrive plus à se lancer et je me retrouve en mode console.

En faisant CTRL+ALT+F5 , on voit qu'Il bloque juste après avoir indiqué :
/dev/sdc Setting Advenced Power Management level to 0xfe (254) [OK]

J'ai une GeForce 7900GS en 1920x1080 et tout marchait bien avant passage à 9.10

Y a t il une procédure de récupérer l'interface graphique ? Avez vous une idée ?

Je vous remercie d'avance.

Doudy

Ubuntu 12.10

Poste le Sunday 26 April 2009 01:40:17
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

bonjour,

sauvegarde ton fichier xorg.conf en le renommant puis essaie un fichier xorg.conf simple en vesa comme par exemple:

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "i2c"
# Load "bitmap"
# Load "ddc"
# Load "dri" ## direct rendering
# Load "extmod"
# Load "freetype"
# Load "glx" ## client GLX pour OpenGL
# Load "int10"
# Load "type1"
# Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
# Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "Auto"
EndSection

Section "Device"
Identifier "Carte"
Driver "vesa" ## nv pour les NVIDIA (libre), ati pour les ATI (libre).
# BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Moniteur"
Option "DPMS"
## HorizSync 31-60 ## selon vos valeurs, n'est pas toujours nécéssaire.
## VertRefresh 47.5-125 ## voir [www.monitorworld.com]
EndSection

Section "Screen"
Identifier "Ecran"
Device "Carte"
Monitor "Moniteur"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Ecran"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Poste le Monday 27 April 2009 11:07:17
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Merci de l'aide, mais même un xorg.conf simple en vesa ne marchent pas.
J'ai l'impression que le problème est ailleurs.
Le fait de compiler le pilote NVIDIA a du aussi toucher au noyau , en effet j'ai l'erreur suivante au démarrage, lorsque je fais ctrl+Alt+F1:

starting up ...
Loading please wait ..
19+0 records in
19+0 records out
Kinit: name_to_dev_t (/dev/disk/bu-uuid/a24b79f6-b780-40b1-8bda-a9e7a610b37c) = dev(8,21)
kinit: trying to resume from /dev/disk/by-uuid/a24b79f6-b780-40b1-8bda-a9e7a610b37c
kinit: No resume image, going normal boot ...

Ubuntu 9.04 TOTO tty1

TOTO login:

Je suis sur le kernel 2.6.28-11 generic

Que puis-je entreprendre au niveau de la console pour rétablir un démarrage normal ?

Merci de votre aide

Doudy

Ubuntu 12.10

Poste le Monday 27 April 2009 12:54:23
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

toucher au noyau, tout dépend de ce que l'on entend par toucher; mais je ne pense pas.
Par contre, peut être qu'un module nvidia est effectivement chargé qui en modifie le comportement.

D'après ce que j'ai lu rapidement ici (https://bugs.launchpad.net/ubuntu/+bug/103148), les infos de kinit ne sont pas forcément un pb

peux-tu effacer le buffer de trace kernerl par un dmesg -c
faire la même chose avec le log de /var/log/Xorg.0.log

puis redémarrer et poster ici ces traces ?
dmesg (commande) et /var/log/Xorg.0.log (fichier) ?

Poste le Monday 27 April 2009 13:27:13
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

j'ai fait:

dmesg -c
dmesg /var/log/Xorg.0.log

puis:

shutdown now

alors s'affiche le recovery menu de Linux

puis cancel

et redémarrage

Et je ne sais pas comment vous envoyer la trace et le fichier:dmesg (commande) et /var/log/Xorg.0.log (fichier)
mais comme je suis en réseau (Je ping bien la machine qui a le problème ) et mon autre machine est aussi sous Ubuntu peut être que je peux ouvrir la console de la machine à problème depuis mon autre machine pour faire les manip ? .Mais comment ?

Ubuntu 12.10

Poste le Monday 27 April 2009 14:39:38
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

je ne comprends pas pourquoi ta machine reboot ?
elle le fait automatiquement ?

le menu que tu appelles recovry est le menu multiboot de grub ?
si tu veux une console seule d'ailleurs, tu peux choisir le boot en failsafe durant ce menu de selection

je lis que tu as fait la commande: dmesg /var/log/Xorg.0.log

en fait ce sont deux commandes séparées et pour être plus juste, dmesg est une commande alors que /var/log/Xorg.0.log est un fichier.

Tu peux donc enregistrer le resultat de dmesg par un : dmesg > /tmp/dmesg.log
puis le contenu de /var/log/Xorg.0.log tu peux l'afficher par cat /var/log/Xorg.0.log
par exemple

Poste le Monday 27 April 2009 15:05:50
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Non, non, je me suis mal expliqué: ma machine ne reboot pas automatiquement, c'est moi qui la redémarre avec un shutdown ..

Ce que j'appelle "recovery menu" n'est pas le Grub

C'est un menu en mode caractère semi graphique qui s'affiche après avoir envoyé le shutdown. Pour mieux comprendre j'ai une photo d'écran en ici :
en dessous il y a 2 autres choix qui ne sont pas sur la photo:
root : Drop to root shell prompt
xfix: Try to auto repar graphic problems


Ensuite comment récupérer le trace de la commande et le fichier pour te l'envoyer sur le forum. Ne puis- je pas récupérer ces 2 fichiers depuis une autre machine Linux de mon réseau, mais comment ?

Ubuntu 12.10

Poste le Monday 27 April 2009 15:36:04
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

juste pour le test, je pense que tu fais un "shutdown now" et pas un "shutdown -h now" non ?
la commande "propre" est celle avec le -h (pour halt), et je pense que tu ne devrais plus avoir le recovery menu ?

peux-tu le vérifier ?

Poste le Monday 27 April 2009 15:43:33
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

ensuite pour la recopie de fichier de machine à machine....
et bien... il y a beaucoup de solutions différentes....

que peux-t-on essayer ?
as-tu un ftp sur tes machines ? ou alors on fait un rsync ?
tu dois avoir rsync dans /etc/init.d ?

Poste le Monday 27 April 2009 15:50:03
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Oui exact, avec "shutdown -h now" il s'arrête directement sans m'afficher le recovery menu.

Maintenant le problème c'est: comment envoyer les fichiers de capture de commande vers mon autre machine Linux du même réseau local, pour que depuis cette machine envoyer les fichiers sur le forum ??

Ubuntu 12.10

Poste le Monday 27 April 2009 15:59:12
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

plus simple encore car j'espère que tout est prêt pour cela sur tes machines.
On passe par ssh et scp ?

appelons A la machine sur laquelle tu as ton pb X et B ta seconde machine.

peux-tu vérifier que tu as bien /etc/init.d/ssh sur A ?
si c'est le cas, essaie de faire /etc/init.d/ssh start

cela va demarrer le demon ssh sur A pour que B puisse s'y connecter.

Ensuite depuis B tu peux essayer:

ssh <username>@<adresse IP de A>
et tu seras sur A en mode console depuis B
bon cela n'aide pas a la copie mais tu as alors accès à A en console depuis B et on a vérifié que SSH fonctionne bien.

tu peux quitter cette console par un exit (classique)

et maintenant sur B tu fais:
scp <username>@<IPdeA>:<le fichier a copier> .

et si tout va bien, tu devrais avoir le fichier <le fichier a copier> sur B

Poste le Monday 27 April 2009 16:00:32
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

nos messages se sont croisés ... je vérifie si j'ai ftp ou rsync sur les 2 machines ...

Ubuntu 12.10

Poste le Monday 27 April 2009 16:01:26
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

attention au "." en fin de commande
scp <username>@<IPdeA>:<le fichier a copier> .

pour indiquer que l'on copie le fichier dans le rép courant !

Poste le Monday 27 April 2009 16:02:08
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Sur A je n'ai pas de /etc/init.d/ssh

toutefois si je fais:
sudo ssh start

j'a un message disant:
Could not resolve hostname start: name or service not known

Ubuntu 12.10

Poste le Monday 27 April 2009 16:12:09
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

tu ma parles de demon ssh, et si je fais

sshd start

il me dit que openssh-server n'est pas installé

donc je vais faire un apt-get install openssh-server ...

Ubuntu 12.10

Poste le Monday 27 April 2009 16:20:43
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

nickel... j'attends la suite spinning smiley sticking its tongue out

Poste le Monday 27 April 2009 16:23:30
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

super , maintenant j'ai /etc/init.d/ssh

je fais la manip indiquée

Ubuntu 12.10

Poste le Monday 27 April 2009 16:23:40
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

Parfait, ça a marché.
Je note bien cette manip pour la prochaine fois !

Mais le contenu de ces fichiers est très long, n'y a t il pas un moyen de les mettre en pièce jointe sur ce forum?

A moins de faire un lien sur un serveur style Servimg.com qui accepte les fichiers texte, en connais-tu ?

Ubuntu 12.10

Poste le Monday 27 April 2009 16:47:22
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: gil390

oui, je me doute que le contenu est long sad smiley

tu peux faire un tar/bzip ?
et tu envoies sur [dl.free.fr]

a la fin du telechargement tu auras juste à me communiquer ici le lien de récupération que le site de free t'indiquera et ce sera ok.

pour eviter que cela soit trop long, tu peux vider ces fichiers:
dmesg -c
et rm du Xorg...log

et shutdown -r now de la machine A puis récupérer les fichiers plus "épurés" avec seulement les traces du dernier lancement.

sinon envoie quand même...

Poste le Monday 27 April 2009 16:51:43
Répondre     Citer    
Re: Démarrage interface graphique impossible aprés installation NVIDIA
Envoyé par: doudy

c'est bon, j'ai trouvé:

Xorg.O.org

et

dmesg.log

Ubuntu 12.10

Poste le Monday 27 April 2009 16:56:27
Répondre     Citer    
Aller à la page:  1 2 Page suivante
Page: 1 sur 2

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Démarrage interface graphique impossible aprés installation NVIDIA
Vous voulez savoir si votre matériel est supporté par Linux, ou vous avez un problème pour installer un module ? Ce forum est pour vous !
Nouveau sujet sur ce forum

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons