Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
systemd : mon service affiche inactive(dead) alors qu'il a bien lancé mon script
Envoyé par: cosmoff

Bonjour à tous,

je débute sur linux, et je bloque sur un probleme.

Voila dans le répertoire /lib/systemd/system j'ai crée un fichier de config cosmoff.service :
Code :
[Unit]
Description=service de cosmoff
ConditionFileIsExecutable=/usr/bin/cosmoff.sh
After=rc-local.service

[Service]
Type=simple
ExecStart=/usr/bin/cosmoff.sh
RemainAfterExit=yes

et donc systemd est sensé lancé mon script cosmoff.sh:
Code :
#!/bin/bash
mkdir -p /home/cosmoff/dir_created
exit 0

et je constate qu'a chaque démarrage de mon pc il crée bien mon répertoire (que je supprime avant de redémarrer).
Mais quand je fais :
systemctl status cosmoff.service, le terminal me retourne :

Loaded: loaded (/etc/systemd/system/cosmoff.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Sun 2019-06-30 12:02:42 CEST; 3min 56s ago
Process: 1109 ExecStart=/usr/bin/cosmoff.sh (code=exited, status=0/SUCCESS)

or je m'attendais plus a ce qu'il marque : Active: active(exit) et non Active: inactive (dead). car systemd a bien lancé mon scrit et le script a fini sans erreur.

Merci d'avance pour vos éclaircissements

Poste le Sunday 30 June 2019 13:42:49
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
systemd : mon service affiche inactive(dead) alors qu'il a bien lancé mon script
Un problème avec une commande du shell ? Comment utiliser la crontab ? Vous avez des soucis pour la gestion réseau sous Linux ? Pour vous la gestion des utilisateurs/groupes est du chinois ? Etc... Posez donc vos questions ici.

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons