Léa-Linux & amis :   LinuxFR   GCU-Squad   GNU
Lea Linux:Rapport d'erreurs/Corrigés

[Retour]

Réglés

  • Fred 10 jan 2006 à 16:02 (CET)
    • La petite flèche qui déroule les contributions multiples sur un même article dans Special:Recentchanges est remplacée par un + et cliquer dessus ne déroule pas (Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)). Nicola 23 déc 2005 à 13:01 (CET) <cadre>bug:erreur dans le déplacement d'un répertoire</cadre>
  • Fred 28 oct 2005 à 10:17 (CEST)
    • Le moteur mediawiki(?) a récemment fait apparaître
      dans les pages Catégories:(...). Du coup ça affiche un grand blanc. --Mike-m 28 oct 2005 à 01:54:41 (CEST)
    • notafish }<';> 26 oct 2005 à 00:06 (CEST) orthographe : le "contribution de l'tilisateur" qui devrait dire "contributions de l'utilisateur". amha.
  • Fred 27 oct 2005 à 10:10 (CEST) : fait (et oui tu passes pour un affreux : mais chez Léa on aime les affreux)
    Vincent Ramos 27 oct 2005 à 04:33 (CEST) Corriger page précédante en page précédente dans la page de modération. Pour la même page, je suggère une plus grande cohérence en mettant tous les verbes à l'infinitif et autres : « Gèrer la modération sur Léa, Effacer le cache, Actualiser l'affichage, Vider le Nettoyage du cache, Afficher les modérations, Actualiser Relire la liste des fichiers, Aide ». Je suggère, hein, je ne voudrais pas passer pour un affreux.
  • Fred 26 oct 2005 à 22:33 (CEST) : corrigé
    Vincent Ramos 26 oct 2005 à 14:51 (CEST) : l'orthographe du message d'avertissement lors d'une modification (normalement MediaWiki:Copyrightwarning ou MediaWiki:Copyrightwarning2 mais cela ne semble pas le cas dans cette mouture du wiki : Fred: non pour des raisons de vitesse on n'utilise pas la base de donnée pour lire les messages mais le tableau - c'est une option de mediawiki, d'après les développeur on gagne 20 à 60% de temps de calcul par page )
  • (Fred 26 oct 2005 à 10:28 (CEST)) réglé :
  • notafish }<';> 25 oct 2005 à 23:38 (CEST) Quand je clique sur la page de Vincent (qui pourtant semble avoir quelque chose dessus, je suis renvoyée à la page d'accueil ? quid ? Pas vrai avec les autres.
    Le bug est vraiment vicieux ... si on met "Vinc" en n'importe quelle position du nom de page on est redirigé vers l'accueil ... je cherche mais ne comprends pas ... exemple : BlaVincBlabla mais pas (enfin j'ai pas encore trouvé d'autres chaines qui le fond) avec autre chose que "Vinc" ... vraiment très étrange.
    Cela n'arrive qu'avec la version en cache du site : j'imagine que c'est une histoire de page qui ne peut être servie (problème de cache ?), d'où un 404 avec redirection vers la racine du site, non ? Ce bug n'apparaît pas dans la version non cachée. Vincent Ramos 26 oct 2005 à 02:57 (CEST)
    oui j'ai remarqué cela aussi, c'est trés étrange, si je supprime le .htaccess contenant des rewrite rule c'est quand même redirigé vers l'accueil (normal aucune règle ne devrait matcher Vinc à cet endroit de l'url) et si en plus je remplace le 404.php qui gère le cache lui-même, la redirection a lieu quand même ... ça me laisse plus que perplexe (surtout, ce qui m'étonne, c'est pas que j'ai pu merdé un truc : ça je suis spécialiste, c'est que ça arrive qu'avec "Vinc" pourquoi donc "Vinc" ? J'ai absolument aucune piste
    encore plus étrange: sur devel.lea-linux.org et lea-linux.org il y a en ce moment exactement le même site (lien symbolique vers le même rep pour les deux vhosts) et bien le comportement n'est pas le même, il revient au même (affichage de l'accueil) mais dans un cas via une redirection, dans l'autre affichage direct de la page Accueil semble-t-il sans redirection) ... je patauge dans la semoule.
    on progresse, en fait c'est pas Vinc qui pose problème mais "inc" ... comme include ... une piste ? ou pas ? mystère ! Fred 26 oct 2005 à 03:21 (CEST)
    Waouh, quel jolie recherche de bug ! Vincent Ramos 26 oct 2005 à 11:28 (CEST)
    trouvé ! c'était une erreur de la configuration d'apache un <Files ~ ".inc"> à la place d'un <Files ~ "\.inc$">
  • keyes: Petit problème de syntaxe dans l'email de confirmation de création d'un compte. "Quelqu'un, probablement vous avec l' adresse email 82.xxx.xxx.xxx, a enregistré un compte « Keyes » avec cette email sur le site Lea Linux." [...] Bien entendu il s'agit de l'adresse IP, pas de l'adresse email.
    corrigé
    • JoKoT3 28 oct 2005 à 20:28 (CEST) ca n'a pas été corrigé apparement, j'ai eu la même chose aujourd'hui
  • (mike-m) l'upload d'une image ne marche pas, à la place il me demande de me connecter, alors que je le suis déjà
    il faut être éditeur ou plus pour pouvoir uploader des images. Fred 23 oct 2005 à 22:32 (CEST)
    okidoki
  • fait:
    • amélioration de l'interface de modération (recherche par lettre de début, par page)
    • amélioration de la vitesse de l'interface de modération (réduction de la charge serveur) : utilisation d'un cache pour les information de fichier, le répertoire de cache ne sera plus parcouru des 100aines de fois pour juste se promener dans les fichiers du cache.
  • fait: ajouter en bas de chaque article les "autres ressources" des anciens articles
    dans la mesure du possible (ie: j'ai pas cherché à la mano les tritres des articles, un certains nombres de ressources ~ 10, ont été mangées par médiawiki)
  • Lorsque l'on est sur la page des contributions d'un utilisateur, il est affiché Contributions de $1 au lieu du nom de l'utilisateur
    Ce n'est pas un bug, mais il y a une faute de frappe dans les préférences utilisateur: Me prévenir par courrile des changements de ma page
  • affichage correct du fait qu'on soit loggué ou pas : utilisation d'un morceau de code javascript (seule solution que j'ai trouvé, à cause du cache : qui rend certaine page statique alors qu'elles sont toutes dynamiques du point de vue de l'affichage de ce genre d'information). Ce code ne vérifie pas les mots de passe : il suppose que les cookies annoncés sont corrects et bien fixés par mediawiki, si ce n'est pas le cas et qu'un mec essaie de truander, et bien il se retrouve avec un affichage qui lui fait croire qu'il est vraiment loggué, même s'il ne l'est pas. Tant pis pour lui ;-p
  • portage des commentaires de l'ancien wiki dans le nouveau (les pages ne sont certainement pas "trés" correctes, mais ça permettra de les relire
  • lien "ajouter un commentaire en bas de chaque page" qui ajoute un truc à la page "discussion"
  • maj mediawik 1.5rc4 -> mediwiki 1.5.0
  • CSS / Skin LéaLinux : liens d'édition plus lisible + repositionnement des liens d'édition du bas
  • Lea 3 oct 2005 à 17:20 (CEST) (réglé) (jiel) confirmation par courriel lors de la création de compte: quand je clique sur le lien pour confirmer, j'ai "The requested URL /cached/index/Special:Confirmemail/[lettresetchiffres].html was not found on this server.".
  • 3 oct 2005 à 01:21 (CEST) Les "Fiches pratiques" n'affichent rien
    • Ça m’étonnerait… lesquelles ?
    • Moi rien ne m'étonne, mais par contre, je n'ai pas ce problème, de quelle fiche tu parles (url ?) et depuis quelles pages obtiens tu ces url ? (url ?)
    • (jiel) Je pense qu'il veut dire en cliquant dans le menu dans la boite en haut du site, le lien est "http://devel.lea-linux.org/cached/index/Fiches:index.html#" au lieu de "http://devel.lea-linux.org/cached/index/Fiches:Index.html#" (juste la maj qui change en fait). Les fiches sont donc accessibles sur la page d'accueil en bas, mais pas dans la boite en haut.
    • (fred) si c'est ça : alors c'est réglé ... je n'avais pas ce "pb" sur konqi, ça faisait une redirection automatiquement vers la bonne page ... étrange...
  • (2 oct 2005 à 18:22 (CEST) réglé) Pour l'activation du compte, lorsque je clique sur l'url de confirmation une fenêtre de connexion s'affiche, mais il n'a pas l'air d'apprécier mon login/passwd (me réaffiche la fenêtre de login)
    • note : pour activer le compte, il n'est rien besoin de faire : il est activé, d'ailleur tu as posté ce text VIA ce compte ce qui prouve que tu es bien enregistré ET que ton compte fonctionne
    • par contre, la confirmation d'email ne semble pas fonctionner pour toi, puis-je te demander de m'envoyer, l'url qui est dans le mail de confirmation (mais avant, peux-tu recliquer dessus, je crois que je vois ou est le pb et j'espere que je viens de le corriger).
  • je n’arrive plus à éditer ma page utilisateur (nicola), il dit que je ne suis pas connecté, même problème avec pas mal de pages spéciales (semble réglé)
  • création de page (lien en rouge) qui bugue (il y a parfois un / en trop entre edit et index) (may be fixed)
  • la balise code crée un retour à la ligne (fixed)
  • problème avec les "?" dans les noms de pages (enfin j'espère)
  • problème avec les login ne commençant pas par une majuscule : un ucfirst est fait pour éviter ce pb
  • support d’utf-8 (si ce n’est pas déjà fait) : (note de fred: mediawiki est nativement en utf-8)
  • contenu de l'index : Accueil à revoir (urgent) : ce n'est certes pas parfait, loin s'en faut, mais un appel à contribution est lancé.
  • export PDF (urgent) : version partiellement satisfaisante (à améliorer, mais plus tard) accessible via le bouton "Version pdf".
  • login sur nocache avec les identifiants mediawiki
  • protection "fs-overflow" : les pages n'existants pas ne génére rien dans le cache
  • le bouton admin swap de "cached" à "nocache"
  • lien des deux menus à voir (urgent) (FIXED)
  • le renommage de page ne fonctionne pas comme il devrait : la redirection qui suit le renommage renvoie sur la page d'Accueil plutôt que vers la bonne page (FIXED)
  • dans le même ordre d'idée lors de l'upload d'une image, l'upload se fait bien mais la redirection qui suit l'upload merdoit. (FIXED)
  • problème avec les pages a un titre (ou un namespace) comportant des caractères accentués -> après la preview, ces caractères sont remplacés par : %xy%zt etc ... et ça plante le "title" (FRED:FIXED / putain d'UTF-8 de mes deux !)
  • problèmes avec les modèles (FRED:FIXED) :
    • modification de la page Accueil car un modèle s'utilise pour la page [[Modèle:Nom du modèle]] avec le marqueur {{Nom du modèle}} (FRED:FIXED)
    • un seul niveau de catégorie, il faut éditer les pages des sous-catégories pour les inclure dans sa catégorie mère => ajout de [[catégorie:nom de la catégorie mère]] dans la page de la catégorie (Note de Fred: je ne vois pas vraiment ce que tu veux dire) (ST:FIXED par exemple [Catégorie:Applications] appartient à [Catégorie:Léa_pour_les_pros])
    • l'accès en lecture aux modèles en cache est interdit (demande d'identification infinie) et ainsi les modèles ne sont pas résolus pour affichage : peut-être dû au problème de cache et caractères accentués
    • cf doc http://fr.wikipedia.org/wiki/Aide:Modèle
  • problème avec les liens mails, comment écrire un lien mailto en MediaWiki ? (FRED:FIXED) comme ça : mailto:capue@labas.com et pour éviter que ça merdoie : [mailto:capue@labas.com un joli nom] donne : un joli nom
  • les sous sections, sous-sous sections etc... vautre le cache ex: Section/Page : FIXED (mais j'ai l'impression que les "rétro-lien" (ie: vers Section depuis Section/Page ne fonctionnent pas, pour une raison qui m'échappe.
  • version imprimable fonctionnelle
  • FIXÉ : Vincent Ramos 25 oct 2005 à 04:06 (CEST) : la police à utiliser pour les paragraphes sous <code></code> devrait être à chasse fixe (type Courier) et non proportionnelle. Pour certaines lignes de code, il y a des effets gênants (combien y a-t-il de traits d'union dans -- et --- ?) et dans la majorité des cas, c'est inesthétique. D'autre par, la taille de police par défaut est minuscule.
    Peux-tu me montrer une page qui pose un problème ? Merci --Mike-m 25 oct 2005 à 04:17:06 (CEST)
    Par exemple, Gestion des ACL, dont voici une capture d'écran sous Firefox sans réglages particuliers sous Debian. Noter le caractère peu clair de la première ligne de commande. De toute façon, quand je consulte Léa, je suis obligé d'augmenter de manière importante la taille des caractères. Je me demande ce que donne le site pour les mal-voyants. Vincent Ramos 25 oct 2005 à 11:12 (CEST)
    pour les mal voyants : le zoom est leur ami,
    pour le code, je viens mettre la police "courier, fixed" et j'ai supprimé le 90% de taille, (mais il faut reloader la page pour recharcher la CSS) ça devrait être plus lisible.
    La police en général est super fatigante sur mon écran. Et pas jolie du tout (sans anticrénelage, taille défaut trop grande ?) c'est très bizarre. C'est quoi comme police ?notafish }<';>

Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons CC-BY-SA
Powered by MediaWiki