Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Problème d'intégration à un domaine NT
Envoyé par: Tchelome

Bonjour,

je suis actuellement stagiaire en entreprise, et j'ai pour projet de monter un serveur de fichier CentOS 5.4 membre d'un domaine NT.
J'ai à disposition un serveur Windows NT4, Contrôleur Primaire du Domaine, et des clients XP PRO.

Problématique : CentOS ne liste pas les utilisateurs et les groupes du domaine NT quand j'effectue la commande "wbinfo -u" ou "wbinfo -g", alors que sur mon serveur Windows NT, la machine CentOS est indiqué dans le gestionnaire de serveur.
Il renvoie l'erreur suivante : "Error looking up domain users"

Sur ma machine CentOS, j'ai créé une partition "donnees" de 300Go en ext3 pour pouvoir partager des données. (Les acls ont été mise en place)
Pour configurer mon partage, voici les étapes que j'ai effectué :
- Installation de Samba et Winbind

- Modification des paramètres samba à l'aide du fichier /etc/samba/smb.conf, en voici son contenu :
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
#global est la partie permettant la gestion du serveur samba
[global]

#on indique le nom du groupe de travail
workgroup = RICHARD
#on indique le nom du serveur
server string = Serveur de fichiers RICHARD
# place le serveur comme un serveur membre d'un domaine possédant déjà un CPD
security = domain
#les password seront cryptés, ce qui est obligatoire sous samba
encrypt passwords = Yes
#Samba va rechercher automatiquement le contrôleur principal de domaine
password server = *
# utiliser un fichier de trace pour chaque machine qui se connecte
log file = /var/log/samba/log.%m
max log size = 50

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
unix charset = ISO8859-15
os level = 18
local master = No
dns proxy = No
template homedir = /home/%D/%U
template shell = /bin/bash

# section qui permet de définir les partages

[Public] # on indique entre crochet le nom sous lequel le dossier partagé apparaitra sur le réseau .

# chemin du dossier à partager
path = /home/partages/public
# permet l'écriture sur le répertoire
writeable = yes
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- Redémarrage de samba

- Mise en place de Winbind :
-> Pour que Samba prenne en compte Winbind j'ai ajouter dans la partie [global] du fichier smb.conf les lignes suivantes :
idmap uid = 10000-20000
idmap gid = 10000-20000
winbind separator = +
winbind use default domain = yes

-> Modifier les lignes suivantes du fichier /etc/nsswitch.conf :
passwd: files nisplus winbind
shadow: files nisplus
group: files nisplus winbind

- Arrêt de samba

- Ajout du serveur Samba au gestionnaire de serveurs du contrôleur de domaine Windows NT (compte Administrateur ayant droit d'ajouter des serveurs au domaine) :
net rpc join -U Administrateur
-> Réponse : Joined domain "mondomaine"

- Redémarrage de Winbind et de Samba

=> l'inconvénient est qu'il faudra créer manuellement, pour chaque utilisateur du domaine Windows, un utilisateur samba, alors que si dans notre cas CentOS listait les utilisateurs du domaine, il suffirait de synchroniser la liste des utilisateurs de CentOS avec la liste des utilisateurs de samba. (Pour se connecter à un partage, il est nécessaire d'avoir un utilisateur samba) (Mon entreprise compte plus de 400 utilisateurs sur le domaine)

S'il vous plaît, quelqu'un aurait-il une solution ?

Merci de votre attention

Poste le Wednesday 24 March 2010 09:56:51
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Problème d'intégration à un domaine NT
Questions spécifiques à Fedora et ses dérivées : Red Hat Enterprise Linux, CentOS

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons