Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Archive de la liste aide - [Aide] URGENT aide configuration routeur
Bonjour,

Je suis bloqué sur la configuration d'un routeur.

j'ai 2 cartes réseau eth0 (192.168.1.1) et eth1( 10.10.10.1)

ensuite j'ai eth1:0 (10.10.10.2)

J'ai dessus un haproxy

Qui lui prend le traffic 80 de eth1 (10.10.10.2) et l'envoi en interne 
vers 192.168.1.100 et 192.168.1.101 et 192.168.1.102

j'utilise ufw pour le router. j'arrive a peu prés (tant qu'il n'est pas 
surchargé) a configurer 192.168.1.100 et avoir le résultat

Mais toutes les requetes vers 192.168.1.101 et 192.168.1.102 ne renvoi 
rien alors que je vois que les serveur travail et répondent.

before.rules:

-A POSTROUTING -s 192.168.1.0/24 -o eth1 -j MASQUERADE

-A PREROUTING  -i eth1 -p tcp -d 10.10.10.1 --dport 80 -j DNAT 
--to-destination 192.168.1.50
-A POSTROUTING -s 192.168.1.50 -o eth0 -j SNAT --to-source 10.10.10.1


-A PREROUTING  -i eth1 -p tcp -d 10.10.10.1 --dport ssl -j DNAT 
--to-destination 192.168.1.215
-A PREROUTING  -i eth1 -p tcp -d 10.10.10.1 --dport 4500 -j DNAT 
--to-destination 192.168.1.50
-A PREROUTING  -i eth1 -p tcp -d 10.10.10.1 --dport 4502 -j DNAT 
--to-destination 192.168.1.50
-A PREROUTING  -i eth1 -d 10.10.10.1 -p tcp --dport 225 -j DNAT 
--to-destination 192.168.1.215

les régles de routeur :

ufw allow to  any port 80

Tout le traffic sortant est authorisé.

Je pense que la config est tout a fait pourri. Mais je vois pas ce que 
je dois faire.

Merci d'avance de votre aide;

Cdlt

David






Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons