Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Problème de service networking
Envoyé par: rezolinux

Bonjour à tous,

Meilleurs vœux pour tout le monde.

Dans ma Vm sous l'adresse 91.121.36.11

Voici mon fichier /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 91.121.36.11
        netmask 255.255.255.0
        network 91.121.36.0
        broadcast 91.121.36.255
        gateway 91.121.36.254
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameserver 213.186.33.99 #Serveur DNS OVH
        dns-search ovh.net #Résoudre plus vite les hosts sur le réseau OVH
        post-up route add 91.121.36.254 dev eth0
        post-up route add default gw 91.121.36.254
        pre-down route del 91.121.36.254 dev eth0
        pre-down route del default gw 91.121.36.254

iface eth0 inet6 static
        address 2001:41d0:8:523d::2
        netmask 64
        gateway 2001:41d0:8:52ff:ff:ff:ff:ff
        post-up /sbin/ip -f inet6 route add 2001:41d0:8:52ff:ff:ff:ff:ff dev eth0
        post-up /sbin/ip -f inet6 route add default gw 2001:41d0:8:52ff:ff:ff:ff:ff
        post-up /sbin/ip -6 addr add 2001:41d0:8:523d::2/64 dev eth0
        pre-down /sbin/ip -6 addr del 2001:41d0:8:523d::2/64 dev eth0
        pre-down /sbin/ip -f inet6 route del default gw 2001:41d0:8:52ff:ff:ff:ff:ff
        pre-down /sbin/ip -f inet6 route del 2001:41d0:8:52ff:ff:ff:ff:ff dev eth0

J'ai redémarré le service

/etc/init.d/networking restart

Mais j'obtiens une erreur :


Citation

[warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
[ ok ] Reconfiguring network interfaces...done.

De plus, quand j'essais de mettre Ipv6 public elle n’apparaît pas.

Quand je fais un ifconfig

Code:
eth0 Link encap:Ethernet HWaddr 00:50:56:05:59:55
inet adr:91.121.36.11 Bcast:91.121.36.255 Masque:255.255.255.0
adr inet6: fe80::250:56ff:fe05:5955/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2853 errors:0 dropped:0 overruns:0 frame:0
TX packets:1409 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:494352 (482.7 Kicool smiley TX bytes:501927 (490.1 Kicool smiley

Ce que j'ai mis en gras c'est une adresse IPv6 en local.
A la place je devrais avoir Scope:Glogal.
Je devrais avoir une adresse ipv6 en global public.

J'ai regardé la documentation pour IPv6 sur Ovh.

J'ai remplacé via par gw et -family par -f.

ça fonctionne sur un domaine mais pas sur les autres

[docs.ovh.com]

et

[guides.ovh.com]

Coment puis-je faire ?

Merci

Cordialement,

Poste le Saturday 2 January 2016 16:09:46
Répondre     Citer    
Re: Problème de service networking
Envoyé par: merlin

Bonsoir,

concernant ton message d'erreur, ton debian t'indique que l'init par default est maintenant sytemd(depuis 2014) et qu'il faut utiliser systemctl a la place des script SysVinit.

example :
systemctl restart networking

concerant ton adresse ipv6
peut-tu poster ce que te renvoi un
sysctl -a | egrep '(ra_|router_sol)'

A bientôt

" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

Poste le Tuesday 12 January 2016 22:52:56
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Problème de service networking
Un problème avec une commande du shell ? Comment utiliser la crontab ? Vous avez des soucis pour la gestion réseau sous Linux ? Pour vous la gestion des utilisateurs/groupes est du chinois ? Etc... Posez donc vos questions ici.

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons