Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Caractères spéciaux sur Samba
Envoyé par: msoft

Rebonjour tout le monde,

Lorsque je monte un système de fichier via Samba, les caractères comme les accents sont remplacés par des "?". D'après les messages sur ce sujet, il faut rajouter dans le fichier /etc/samba/smb.conf les lignes:

character set = ISO8859-1
client code page = 850

Mais lorsque que je monte la partition distante l'erreur qui se produit est:

BigMsoft:/mnt# mount -t smbfs //msoftbackup/NetHDD /mnt/MsoftBackUp
Unknown parameter encountered: "character set"
Ignoring unknown parameter "character set"
Unknown parameter encountered: "client code page"
Ignoring unknown parameter "client code page"

La version de samba que j'ai est la 3.0.14 sur une debian

Quelqu'un a une idée, svp ?

Poste le Friday 9 September 2005 16:04:05
Répondre     Citer    
Re: Caractères spéciaux sur Samba
Envoyé par: msoft

Personne n'a déjà eu ce problème ? ?-(
Même pas une petite idée ??

Poste le Saturday 10 September 2005 16:42:49
Répondre     Citer    
Re: Caractères spéciaux sur Samba
Envoyé par: msoft

Ben effectivement la syntaxe des options à indiquer dans le fichier /etc/samba/smb.conf est différente sur Samba-2 et sur Samba-3 en ce concerne les caractères spéciaux et le fameux "character set". Mais puisque tout le monde s'en fiche, ben je m'en fiche de donner la réponse....
:-(

Poste le Sunday 11 September 2005 02:19:24
Répondre     Citer    
Re: Caractères spéciaux sur Samba
Envoyé par: nicola

Non, tout le monde ne s’en fiche pas, mais il est plutôt probable que tout le monde ne le sait pas. Par exemple je n’utilise pas Samba et je suis venu sur ce fil par hasard.

--
On ne prête qu’aux riches, et on a bien raison, parce que les autres remboursent difficilement.
-+- Tristan Bernard (1866-1947) -+-

Poste le Sunday 11 September 2005 07:37:14
Répondre     Citer    
Re: Caractères spéciaux sur Samba
Envoyé par: msoft

Au lieu de mettre "character set" dans /etc/samba/smb.conf, il faut ajouter:
[global]
workgroup = MYGROUP
dos charset = cp850
unix charset = ISO-8859-1


Poste le Sunday 11 September 2005 12:49:25
Répondre     Citer    
Re: Caractères spéciaux sur Samba
Envoyé par: omer92

msoft a écrit:
-------------------------------------------------------
> Au lieu de mettre "character set" dans
> /etc/samba/smb.conf, il faut ajouter:
>
> workgroup = MYGROUP
> dos charset = cp850
> unix charset = ISO-8859-1
>
>

Merci pour la contribution :
en effet, j'avais depuis de mois un message d'erreur dans mes shell:

> Ignoring unknown parameter "character set" <
Je m'en suis débarrassé grace au post.

Je dois avouer de pas comprendre la relation directe entre la configuration Samba et mon bash. Mais en corrigeant le smb.conf, je n'ai plus mon message.

Merci pour la contribution encore utile après 10 ans !

Poste le Monday 1 February 2016 13:30:35
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Caractères spéciaux sur Samba
Un problème avec une commande du shell ? Comment utiliser la crontab ? Vous avez des soucis pour la gestion réseau sous Linux ? Pour vous la gestion des utilisateurs/groupes est du chinois ? Etc... Posez donc vos questions ici.

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons