Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Aller à la page:  1 2 Page suivante
Page: 1 sur 2
audacity fait taire amarok
Envoyé par: Kristen

Bonjour,

Je viens d'installer mandriva spring 2008.1 et tout roulait jusqu'à ce que j'essaie de lancer audacity tout en écoutant la radio avec amarok. Audacity dès son lancement coupe la chique à Amarok. Si je le quitte le son revient.. ???

C'est d'autant plus frustrant que je m'en sers surtout pour enregistrer des programmes radio captés par Amarok.

Merci de votre aide

Kristen

Poste le Monday 16 June 2008 15:15:42
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: jeanbi

bonjour,
qeul gestionnaire de son est utilise par les 2 si c'est oss c'est normal il faut utiliser alsa pour avoir 2 sons en meme temps
perso pour enregistrer je me sert de streamtuner +streamripper + amarok ou audacious comme lecteur .
a+

Poste le Monday 16 June 2008 17:10:55
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: Kristen

J'ai fait un tour dans le centre de config de KDE : c'est bien ALSA qui est le gestionnaire de son.

Poste le Monday 16 June 2008 21:02:08
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: diancech

Audacity utilise oss (donc la couche de compatibilité oss d'alsa) pour le son.

Si ce n'est pas bien configuré quand on utilise deux applications une oss et l'autre alsa il se passe ce qui t'arrive, l'application oss prends le pas sur l'application alsa parce que celle-ci bloque complétement la device de son utilisée.

Pour réussir ce que tu veux faire, cela dépend de ta carte son, supporte t-elle correctement la couche de compatibilité oss d'alsa, si c'et le cas il faut vérifier la configuration pour l'oss d'alsa.

Si ce n'est pas le cas tu peux essayer d'utiliser des démons sonores comme esd, arts, jack, pulseaudio pour arriver à tes fins.

--------------------------------------------------------------------------------------------------------------------------------------------------
Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés. Confucius

Poste le Monday 16 June 2008 23:47:25
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: Triangle

Il n'y pas une option dans la config d'audacity pour utiliser alsa en sortie?
J'utilise rezound qui est plus complet qu'audacity.

Membre de l'APRIL « promouvoir et défendre le logiciel libre » - adhérez vous aussi! www.april.org

Poste le Tuesday 17 June 2008 09:20:30
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: Kristen

Merci à tous.

Voici un tableau plus détaillé de la situation :

1 - par défaut audacity avait comme prériphériques de lecture et d'enregistrement : OSS : /dev/dsp
En le lançant d'abord _puis_ amarok celui-ci se comporte normalement. Mais si j'arrête audacity et le relance avec amarok toujours en marche, ça lui coupe le sifflet...

2 - j'ai changé comme conseillé (merci au fait !) les périphériques le lecture/enregistrement de OSS à ALSA VIA 8237 (hw:0,1) (il y a plein d'autres possibilités ALSA mais je n'y comprends rien et c'est la première). Ça ne change au rien au comportement du couple audacity / amarok : pareil que ci-dessus.

3 - je signale en plus que dans les deux cas, si je lance d'abord audacity puis amarok (pour avoir le son donc), la piste d'enregistrement reste désespérément plate lors de mes essais...

Poste le Tuesday 17 June 2008 19:36:42
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: diancech

Que donnes :

cat /proc/asound/devices



--------------------------------------------------------------------------------------------------------------------------------------------------
Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés. Confucius

Poste le Tuesday 17 June 2008 21:44:29
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: Kristen

Ça donne ça :

[~]$ cat /proc/asound/devices
0: [ 0] : control
1: : sequencer
16: [ 0- 0]: digital audio playback
17: [ 0- 1]: digital audio playback
24: [ 0- 0]: digital audio capture
25: [ 0- 1]: digital audio capture
33: : timer

Poste le Tuesday 17 June 2008 22:00:50
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: diancech

Essaie en mettant le périphérique de capture d'audacity sur hw:0,0 et celui de lecture sur hw:0,1.

--------------------------------------------------------------------------------------------------------------------------------------------------
Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés. Confucius

Poste le Wednesday 18 June 2008 00:09:28
Répondre     Citer    
Re: audacity fait taire amarok
Envoyé par: Kristen

J'ai essayé : aucun changement... Snifff...

Poste le Wednesday 18 June 2008 07:41:08
Répondre     Citer    
Aller à la page:  1 2 Page suivante
Page: 1 sur 2

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
audacity fait taire amarok
Besoin d'aide à propos de musique, son, image, vidéo, etc ... et de Linux ? Vous avez frappé à la bonne porte.
PS: pour les questions technique d'accélération 3D, préférez le forum matériel.
Nouveau sujet sur ce forum

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons