Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Beryl ne fonctionne pas
Envoyé par: yaourt

Bonjour à tous.

Je viens d' installer Beryl sur ma Debian 4.0

Seulement je n' arrive pas à le faire fonctionner... beryl --test-only me donne :

**************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension               : failed

Une petite recherche sur le forum, le problème est connu. il faut activer l' option XComposite dans xorg.conf
Seulement je n' ai pas cette option :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection


Je ne pense pas que ce soit un problème d' incompatibilité, je faisais tourner les effets de Beryl avec un live Cd de Knoppix (sauf le cube, mais je n' avais pas approfondi la question).

J' ai beau chercher, je ne trouve rien d' autre. Quelqu' un a t' il une idée ?

Bonne soirée !

Poste le Wednesday 28 May 2008 00:23:17
Répondre     Citer    
Re: Beryl ne fonctionne pas
Envoyé par: AlSim

Et si tu rajoutes simplement :

Section "Extensions"
  Option "Composite" "Enable"
EndSection
à la fin du fichier ?

[catwell.info]

Poste le Wednesday 28 May 2008 01:17:43
Répondre     Citer    
Re: Beryl ne fonctionne pas
Envoyé par: yaourt

Salut Alsim et merci pour ta réponse.
Cette idée m' a traversée la tête, mais apparament sur certains forums il est déconseillé d' activer cette option; Les avis sont partagés ! Je me suis dit que vu qu' elle n' était pas chez moi d' origine, il y avait peut etre une raison, donc je n' ai pas osé. Mais je vais essayer.
Bon, là il y a de l' orage autour de chez moi,je debranche tout et j' essaye plus tard.

Bonne soirée !

Poste le Wednesday 28 May 2008 20:43:07
Répondre     Citer    
Re: Beryl ne fonctionne pas
Envoyé par: yaourt

Ca y est ! La solution était simple, bien joué merci !
Avant de mettre résolu je vais faire quelques manipulations dessus, voir si tout va bien.

Par contre j' ai failli croire que la modification d' xorg.conf n' avait été sans effet. J' étais passé en mode console puis retour au bureau (ctrl +alt+f1 et ensuite f7) . Normalement le serveur X devrait etre redémarré et les modifications enregistrées non ? J' ai du rebooter ma machine.

Bonne soirée

Poste le Wednesday 28 May 2008 23:21:43
Répondre     Citer    
Re: Beryl ne fonctionne pas
Envoyé par: Léa (Fred)

ctrl+alt+f1 puis f7 ne redémarre pas le serveur X ça change juste de console : les deux (f1 et f7) restant dans l'état au tu les as mises pendant que tu passes sur l'autre.

pour forcer le redémarrage du seveur X :
* la méthode barbare : ctrl+alt+backspace
* la méthode moyen-ageuse : se délogguer puis ctrl+alt+backspace
* la méthode douce : se délogguer, puis sélectionner redémarrer le serveur X depuis la fenêtre de login.

Poste le Wednesday 28 May 2008 23:27:47
Répondre     Citer    
Re: Beryl ne fonctionne pas
Envoyé par: yaourt

Merci Fred pour ces précisions. Pour ma défense sur un autre forum on m' avait dit que la manipulation que j' évoquais suffisait à faire redémarrer le serveur X.
Bonne soirée !

Poste le Wednesday 28 May 2008 23:52:21
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Beryl ne fonctionne pas
Besoin d'aide à propos de musique, son, image, vidéo, etc ... et de Linux ? Vous avez frappé à la bonne porte.
PS: pour les questions technique d'accélération 3D, préférez le forum matériel.

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons