Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
souris ps/2 non reconnu
Envoyé par: General Lee

bonsoir
j'ai un probleme que j'essaye de résoudre depuis plusieurs jours en vain, je n'ai pas trouvé non plus de solution sur internet.
lorsque que je lance le serveur xorg, le curseur de la souris reste immobile au centre de l'écran, il y'a aucune reaction lors de mouvement ou clic souris.
j'ai essayer avec /dev/input/mice et avec /dev/psaux, lorsque que j'ai essayer avec les /dev/input/mouse_, le serveur x plantait direct en me disant periphérique introuvable ; par contre avec mice et psaux le serveur x demarre...
j'ai essayé dans /dev/ avec la commande cat :
- mouse0, mouse1, mouse2, mouse3 < erreur périphérique introuvable
- mice, psaux < aucune erreur mais aucune reaction

par contre, j'ai remarqué que mon probleme est seulement sous la distribution que j'utilise gentoo 2005.1 (avec la 2005.0, il y'a le même souci). j'ai testé avec kaella et ubuntu : la souris marche nickel. le fichier de config "xorg.cong" de ubuntu est le même pour la section souris.

je ne vois pas d'erreur dans le fichier de log concernant la souris...


en fait, j'ai changer de PC et je pense qu'il y'a peut être un conflit matériel. j'ai essayé 5 fois de réinstaller gentoo, sans succès. mais le plus bizard, c'est que la souris marche sous ubuntu et kaella.


au fait, je sais pas si sa à une importance mais ma souris est une 350wl cradle wireless optical de marque trust. c'est une souris 5 boutons avec molette sans fils en PS/2.


voivi la partie souris du fichier xorg.conf :
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
EndSection

voici la partie de Xorg.0.log parlant de la souris :
(**) Option "Protocol" "PS/2"
(**) Mouse1: Device: "/dev/psaux"
(**) Mouse1: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/psaux"
(==) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(==) Mouse1: Buttons: 3
(**) Mouse1: SmartScroll: 1
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "microsoftpro"
(**) Keyboard1: XkbModel: "microsoftpro"
(**) Option "XkbLayout" "fr"
(**) Keyboard1: XkbLayout: "fr"
(**) Option "XkbVariant" "fr-latin9"
(**) Keyboard1: XkbVariant: "fr-latin9"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/share/fonts/local/, removing from list!


si jamais, je peux vous envoyer le fichier log et/ou le fichier de config de xorg complet.


merci d'avance pour vos réponses...

Poste le Thursday 10 November 2005 22:35:10
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: tuxfanch

Salut,
tout a l'air correct, alors je sais pas trop quoi dire ; essaye de configurer ta souris comme une bête souris à molette :
Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "ImPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
EndSection

dans le doute, on sait jamais, mais je ne suis pas très convaincu (disons, qu ça peut être un problème de protocole) ... ?-(

------- <br />
La meilleure façon de prédire le futur, c'est de l'inventer ~ Alan Kay

Poste le Thursday 10 November 2005 23:08:05
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: General Lee

bonjour,
j'avais déja tester en vain... mais j'ai essayer d'enlever quelques options pour voir si c'était pas juste uen des options qui creait le probleme....
pour le prtocole, j'ai déja essayer de le mettre en PS/2, ImPS/2 et auto ; en vain

pensant à une erreur de config du noyau, j'ai essayer ce matin de faire un genkernel, ce qui n'a toujours rien changé....

je sais plus quoi testé.....

surtout que je comprend vraiment pas pourquoi la souris marche avec kaella et ubuntu.... alors que sa marche pas avec gentoo....

Poste le Friday 11 November 2005 11:34:29
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: tuxfanch

Bon, réfléchissons calmement :
1. si ta souris fonctionne avec d'autres distrib, c'est que le matos est OK.
2. j'ai trouvé ça : [forums.gentoo.org] ... ça craint ...
3. à ta place, j'irais configurer moi même le kernel (ce que d'ailleurs il vaut mieux toujours faire) de façon à activer (dans les devices drivers) :
[*] Provide legacy /dev/psaux device
(1280) Horizontal screen resolution
(1024) Vertical screen resolution
(en mettant pour toi la résolution qui va bien)

et

[*] Mice
<*> PS/2 mouse

puis :
genkernel --kernel-config=ton_fichier_de_sauvegarde all

si tu dis que les xorg.conf sont similaires d'une distrib' à l'autre, y'a pas 36 solutions : la différence est nécessairement dans le kernel.

------- <br />
La meilleure façon de prédire le futur, c'est de l'inventer ~ Alan Kay

Poste le Friday 11 November 2005 16:53:28
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: General Lee

merci bien
maintenant sa marche :-), om ma dit de faire le drivers de la souris en tant que module et non en dur. (->Device Drivers -> Input device support -> Mouse -> <M> PS/2 Mouse) et depuis sa à l'air de marcher nickel.

je me disait bien que j'avais du me gourer en configurant le kernel...

Poste le Friday 11 November 2005 18:41:58
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: tuxfanch

pourquoi le driver de la souris en module ? t'as plusieurs souris ? sinon, ça ne change absolument rien dans ton cas. Enfin bon, on s'en fout ; l'important c'est que ça fonctionne correc' :-)

------- <br />
La meilleure façon de prédire le futur, c'est de l'inventer ~ Alan Kay

Poste le Friday 11 November 2005 20:25:01
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: Morgin Devian

Bonjour,

je suis tout nouveau dans le domaine et je viens juste d'installer Devian avec KDE. J'ai ce même problème, cependant je n'ai absolument rien compris à la manip dite ci-dessus.

Pourriez vous me dire (exactement...) ce que vous faites ?

Je vous remercies d'avance.

Morgin

Poste le Tuesday 8 July 2008 10:33:34
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: diancech

Cette manipulation est pour la distribution Gentoo donc tu ne pourras pas l'appliquer sous debian (en tout cas pas de la même manière).

Le mieux serait que tu ouvres un nouveau sujet pour ton problème dans le forum consacré à Debian : [lea-linux.org]

En y décrivant ton problème, les symptômes et en donnant des informations sur le matériel posant problème ainsi que sur ton ordinateur.

Si c'est un problème de souris tu peux déjà inclure (entre les balises code) dans ton post les fichiers : /etc/X11/xorg.conf et /var/log/Xorg.0.log

--------------------------------------------------------------------------------------------------------------------------------------------------
Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés. Confucius

Poste le Tuesday 8 July 2008 14:11:33
Répondre     Citer    
Re: souris ps/2 non reconnu
Envoyé par: Morgin debian

Merci beaucoup.

Poste le Tuesday 8 July 2008 14:24:23
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
souris ps/2 non reconnu
Forum dédié aux questions sur les distributions basées sur les sources : Gentoo, Lunar, Sabayon, Sorcerer, Source Mage

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons