Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Caractères accentués avec RedHat
Envoyé par: Duke

Bonjour à tous,

J'ai installé une RedHat 9 hier (j'avais une RedHat 8 avant et une Mandrake 9 encore avant).

Mon souci est que les RedHat n'affichent pas les caractère accentué des noms de fichiers et répertoire (surement un problème de normes ISO sur les caractères) il affiche des caractères incompréhensibles. Avec la Mandrake, je n'ai jamais rencontrer ce problème.

En fait, le mot "répertoire" s'affiche "r$Ãpertoire" sous X et r?pertoire sous un shell.

Je ne peut donc pas accéder aux fichiers et dossiers dont le nom contient un caractère accentué qui n'aurait pas été saisie depuis une RedHat.

Comment je peu paramétrer mon système pour qu'il affiche correctement les caractères accentués ?

Merci

Poste le Tuesday 11 November 2003 15:19:30
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: gill


moi j ai pas ca sur la redhat 7.3, tout au moins dans le terminal

répé s affiche bien répé,

par contre en conseole, répé s'affiche r{p{

bah je mets jamais de caracteres accentues dans les noms

pourtant je suis bien en font francaises

Poste le Tuesday 11 November 2003 21:11:29
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: fraazz

voilà le contenu de mon /etc/sysconfig/i18n (RH9 > FC1) :

LANG="fr_FR.UTF-8"
SUPPORTED="en_GB.UTF-8:en_GB:en:en_US.UTF-8:en_US:en:fr_FR.UTF-8:fr_FR:fr"
SYSFONT="latarcyrheb-sun16"

aucun pb avec les caractères accentués dans les noms de répertoires sous X ou dans bash ...

Poste le Tuesday 11 November 2003 21:40:07
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: gill


tiens ?

j ai pas tous ces lang, notamment fr_FR.UTF-8, ni fr_FR, ni fr dans /usr/lib/locale

y'a une raison ?

Poste le Tuesday 11 November 2003 21:55:31
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: fraazz

gill > j'en sais rien, pendant l'install j'ai choisi le français par défaut + anglais gb + anglais us

Poste le Tuesday 11 November 2003 22:13:47
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: Paul

En mode console virtuelle, l'affichage des caractères accentués dépend du mappage du clavier avec des touches à caractères accentués, fr_FR, fr_CA, etc et que la police de caractères choisie prenne en charge les caractères accentués. Les variables locales d'environnement doivent aussi dire au SHELL quelle langue utiliser. À préciser dans le fichier de configuration du SHELL. Ex:

# loadkeys cf (fr pour la france)
# setfont -v lat0-16
# locale
LANG=fr
LC_CTYPE="fr_CA"
LC_NUMERIC="fr_CA"
LC_TIME="fr_CA"
LC_COLLATE="fr_CA"
LC_MONETARY="fr_CA"
LC_MESSAGES="fr_CA"
LC_PAPER="fr_CA"
LC_NAME="fr_CA"
LC_ADDRESS="fr_CA"
LC_TELEPHONE="fr_CA"
LC_MEASUREMENT="fr_CA"
LC_IDENTIFICATION="fr_CA"
LC_ALL=fr_CA

Pour le français canadien. fr_FR pour la France.



Paul

Poste le Wednesday 12 November 2003 18:13:23
Répondre     Citer    
Re: Caractères accentués avec RedHat
Envoyé par: Paul

Sous X, il faut mapper le clavier dans /etc/X11XF86Config-4:

Option "XkbLayout" "fr"

Dans KDE, il faut que le paquetage kde-i18n-fr-version-de-kde soit installé, utiliser Kpersonalizer pour activer la français et par Kcontrol choisir le clavier français.



Paul

Poste le Wednesday 12 November 2003 18:19:37
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Caractères accentués avec RedHat
Posez dans ce forum les questions qui ne trouvent pas place dans les autres...

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons