Léa-Linux & amis :   LinuxFR   GCU-Squad   GNU
Help ! installation rpm-build
Envoyé par: Archer

Là, je patine...
Je veux installer une JVM sur ma mandrake 10.1 en procédant comme indiqué sur la fiche [lea-linux.org]
Pour l'instant, impossible d'installer rpm-build.
Je l'ai téléchargé dans /tmp, mais rien n'y fait :
Citation

[root@ip-132 tmp]# urpmi rpm-build
no package named rpm-build
Qu'à celà ne tienne
Citation

[root@ip-132 tmp]# rpm -Uvih rpm-build-4.2.2-7mdk.i586.rpm
error: Failed dependencies:
autoconf is needed by rpm-build-4.2.2-7mdk
automake is needed by rpm-build-4.2.2-7mdk
rpm = 4.2.2-7mdk is needed by rpm-build-4.2.2-7mdk
J'ai déjà mis quelques heures à installer autoconf et automake, et il ne le trouve pas @#%!

Maintenant, je me trouve dans une boucle de dépendance :
rpm-4.2.2-7 <= popt-1.8.3-9 <= glibc-2.3.3-21
Or
Citation

[root@ip-132 tmp]# urpmi glibc-2.3.3-21mdk.i586.rpm
Everything already installed
En faisant une recherche, j'ai trouvé un glibc-devel-2.3.3 dans usr/share/doc.
J'ai voulu le virer pour réinstaller la version simple, mais c'était manifestement pas une bonne inspiration
Citation

[root@ip-132 tmp]# urpme glibc
removing package basesystem-10.1-1mdk.i586 will break your system
Nothing to remove
Sur Windows, il m'a fallu 2-3 minutes. Ici, j'ai l'impressio d'etre face à un abime.
HEEEEEEEEEEEEEEEEEEEEEEEEEEELP ! :-cb:-cb:-cb:-cb



Poste le Monday 15 August 2005 18:06:54
Répondre     Citer    
Re: Help ! installation rpm-build
Envoyé par: Archer

Je progresse : la version du rpm n'était pas la bonne. Il me reste ça :
Citation

[root@ip-132 tmp]# rpm -Uvih rpm-build-4.2.2-15mdk.i586.rpm
error: Failed dependencies:
autoconf is needed by rpm-build-4.2.2-15mdk
automake is needed by rpm-build-4.2.2-15mdk
Une idée ?

Poste le Monday 15 August 2005 18:28:30
Répondre     Citer    
Re: Help ! installation rpm-build
Envoyé par: twocats

Citation

urpmi rpm-build

Si tu as configuré urpmi, si tu as lu la doc, etc...

-------------------
La réponse est 42

Poste le Monday 15 August 2005 19:03:13
Répondre     Citer    
Re: Help ! installation rpm-build
Envoyé par: Archer

?-( Non. Quelle doc ?
Jusqu'à présent, j'avais l'impression que la commande urpmi fonctionnait bien sans que j'y mette davantage mon nez.

Poste le Monday 15 August 2005 19:10:22
Répondre     Citer    
Re: Help ! installation rpm-build
Envoyé par: Archer

Je crois avoir pigé. urpmi un peu mieux configuré => j'ai ce que je veux... pour l'instant.
Merci pour le rappel !

O:-)

Poste le Monday 15 August 2005 19:37:57
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Help ! installation rpm-build
Posez dans ce forum les questions qui ne trouvent pas place dans les autres...

Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons