Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Hubicfuse : problème de permissions / propriétaire
Envoyé par: Spooky

Salut !

J'ai découvert Hubic (OVH) y'a pas longtemps et je veux en faire ma solution de sauvegarde de mes données. C'est possible en utilisant Hubicfuse, qui permet de monter son cloud Hubic dans un répertoire.
Je me suis aidé de ce tuto, ça fonctionne, le répertoire est bien monté, je peux lire et écrire dedans, enfin presque …

J'utilise Owncloud pour synchroniser mes fichiers entre plusieurs ordinateurs. C'est héberger son mon Odroid XU4 avec Armbian. Il faut que l'utilisateur www-data soit le propriétaire du répertoire. Ce que j'ai fait, sauf que ça ne marche pas. J'aimerai ne pas avoir a mettre des permissions trop "souple" parce-que évidemment si je fait 'chmod o+rwx' ça marche très bien mais c'est sale …

Malgré le fait que j'ai indiqué les options uid=33 et gid=33 (www-data) pour fuse dans le fstab et que un 'ls -l' me dit que je dossier appartient a www-data, et pourtant on dirait pas !
La commande 'mount' me retourne :
hubicfuse on /mnt/owncloud type fuse.hubicfuse (rw,relatime,user_id=0,group_id=0,allow_other)
alors que mon fstab contient ça :
hubicfuse /mnt/owncloud fuse uid=33,gid=33,umask=007,noauto_cache,sync_read,allow_other 0 0

Une idée ?
Merci d'avance.

Poste le Tuesday 21 June 2016 16:14:10
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Hubicfuse : problème de permissions / propriétaire
Un problème avec une commande du shell ? Comment utiliser la crontab ? Vous avez des soucis pour la gestion réseau sous Linux ? Pour vous la gestion des utilisateurs/groupes est du chinois ? Etc... Posez donc vos questions ici.

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons