Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Problème NE2000 sous Slackware 12.0
Envoyé par: TheVoice

Bonjour,

J'ai présentement des systèmes embarqués utilisant des cartes réseau NE2000 (RTL8019AS). J'ai utilisé ces cartes avec succès durant des années avec Slackware 10.1 kernel 2.4. Depuis ma première installation Slackware 12.0 kernel 2.6.21.5 (celui de base), ça ne fonctionne pas. La carte est détectée au boot :

NE*000 ethercard probe at 0x220: XX XX XX XX XX XX
eth%d: NE2000 found at 0x220, using IRQ 5.

Nottez-bien le %d dans eth... par le passé (Slackware 10.1) il était toujours détecté sous eth0.

À la fin du boot, ifconfig n'affiche aucune autre carte que lo (loopback). Même en forçant ifconfig eth0 ... ça fait l'erreur comme si la carte n'existait pas.

En vérifiant avec lsmod, les modules sont bel et biens loadés. (ne et 8390)

Merci de votre aide!

Alex

- [tv-t.com] -

Poste le Saturday 26 April 2008 21:59:29
Répondre     Citer    
Re: Problème NE2000 sous Slackware 12.0
Envoyé par: Gargamel

Salut,

Visiblement, il y a un support spécial pour ce type de carte dans /etc/rc./rc.modules (lignes 383-389) :

# NE2000/NE1000 support (non PCI):
#/sbin/modprobe ne io=0x300 # NE2000 at 0x300
#/sbin/modprobe ne io=0x280 # NE2000 at 0x280
#/sbin/modprobe ne io=0x320 # NE2000 at 0x320
#/sbin/modprobe ne io=0x340 # NE2000 at 0x340
#/sbin/modprobe ne io=0x360 # NE2000 at 0x360
# PCI NE2000 clone support:
#/sbin/modprobe ne2k-pci

Si la tienne n'est pas PCI, j'essaierais donc une commande genre /sbin/modprobe ne io=0x220.

Poste le Monday 28 April 2008 10:58:09
Répondre     Citer    
Re: Problème NE2000 sous Slackware 12.0
Envoyé par: TheVoice

Citation
Visiblement, il y a un support spécial pour ce type de carte dans /etc/rc./rc.modules (lignes 383-389) :
Texte à citer

Effectivement, j'ai mis cette commande intégralement dans le fichier, la carte est une PC/104 (format ISA pour systèmes embarqués).

J'ai refais plusieurs tests avec la même configuration (carte et commande)

Slackware 10.1 kernel 2.4.29 : Fonctionnel
Slackware 11.0 kernel 2.6.17.3 (Celui dans testing) : Fonctionnel
Slackware 12.0 kernel 2.6.21.5 : Non-fonctionnel (détection avec eth%d au boot, aucun eth* avec ifconfig)
Slackware 12.0 kernel 2.6.24.5 (Celui de slackware 12.1 RC1) : Fonctionnel avec eth2, détecté en tant que eth0 au boot... étrange mais bon ça me va pour le moment smiling smiley

Je considère donc le problème patché plutôt que résolu totalement.

Merci!

Alex.

- [tv-t.com] -

Poste le Monday 28 April 2008 11:07:36
Répondre     Citer    
Re: Problème NE2000 sous Slackware 12.0
Envoyé par: TheVoice

Bon je vois que j'ai pas compris le fonctionnement des citations smiling smiley prochaines fois!

- [tv-t.com] -

Poste le Monday 28 April 2008 11:09:57
Répondre     Citer    

Veuillez vous authentifier auparavant pour commenter.

 

Ce forum !
Problème NE2000 sous Slackware 12.0
Aide aux utilisateurs de la distribution Slackware et ses dérivées : Slax, Vector

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons