Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Hardware-hard imp-hpijs

Drivers HPIJS pour Hp deskjet

Drivers HPIJS pour Hp deskjet
Installer son imprimante HP Deskjet 6xx/9xx/x

Introduction

Vous avez une imprimante HP Deskjet de série 8xx, 9xx ou supérieure (série 3xx supportée) ?
Alors vous allez pouvoir tirer partie de toutes* les fonctions de cette imprimante, entre autres et surtout de la technologie Photoret {2-3}.

Notez toutefois que la Mandrake 8.1 devrait intégrer directement ces drivers.

Pré-requis

Attention: ce drivers ne marche que pour les imprimantes des séries 6xx,8xx,9xx et supérieures (la série 3xx est supportée).

Vous aurez besoin de :

  • ghostscript-utils-5.5
  • ghostscript-fonts-5.5
  • ghostscript-5.5

Tout ceci est normalement disponible sur le cd de votre distribution.
Je vous conseille aussi d'installer ghostscript-png et jpg pour pouvoir imprimer des images sans soft particulier avec les commandes classiques.

Il vous faut maintenant le support HP de Ghostcript que vous pourrez trouver sur http://hpinkjet.sourceforge.net.

Téléchargez :

  • ghostscript-hpijs-5.50-5 (le support ghostscript)
  • hpijs-0.9*-* (le "driver" et le daemon)

Vous devez posséder un installeur de spooler, genre printtool, ou printerdrake (éventuellement voir sur http://freshmeat.net), ainsi que les packages suivants (à cause des problèmes de dépendances) :

  • mpage-2.5.1-*
  • rhs-printfilters-*
  • control-panel-* (nécessaire seulement pour printtool)

Normalement tout ceci est disponible sur le cd de votre distribution (peut-être des problèmes avec la Mandrake 8.x ?)

Mise au Point

  • Je ne détaillerai que l'installation en rpm, car la compilation a de grande chance de rater si vous n'utilisez pas une distrib "rpm-like" (i.e. RedHat, Mandrake...)
  • L'installation marche très bien avec un server lpd (commande lpr), je ne peux malheureusement pas le certifier pour Cups ou autre.

Installation

Voila avec tout ça, ça devrait marcher ;)

Il suffit donc d' installer les packages que vous n' avez pas encore, et d' installer ceux de Hp avec la commande rpm -Uvh xxx.rpm --force. Normalement aucun problèmes .... nan ils viennent après :
Rpm nous prévient (ou pas) que la base printerdb n'a pas pu être mise à jour.

Nous allons donc le faire nous-même :
Localisez votre fichier printerdb, normalement dans :

/usr/lib/rhs/rhs-printfilters/

Ensuite il suffit de copier les entrées qui nous intéressent du fichier :

/usr/doc/hpijs-0.97/printerdb_append

Copiez dans /usr/lib/rhs/rhs-printfilters/printerdb la ou les entrées de votre ou vos imprimantes.

EX:

StartEntry: HPDeskJet9xx
GSDriver: DJ9xx
Description: {HP - developed DeskJet 900C series}
About: { \
This driver was developed by Hewlett-Packard Co. for deskjet \
930/932C, 950/952C, 970C, photosmart 1000/1100 printers. \
Duplex printing is not supported. \
Different print modes can be specified with the Extra GS option "-dPr
intMode=n". \
Where n equals one of the following values: 0=grayscale, 1=normal (de
fault), or 2=photo. \
Resolution setting 600x600 is available for photo mode only. \
}
Resolution: {300} {300} {}
Resolution: {600} {600} {}
EndEntry

Pour une imprimante de la série 9xx comme ma 930c ;)

Ensuite il n'y a plus qu'à ajouter un spooler pour celle-ci avec le programme de votre choix, genre printtool (non testé) ou printerdrake (parfait).
Notez que pour une imprimante usb, le port est /dev/usb/lp0

Et voilà, comme ça vous allez pouvoir imprimer avec une bonne qualité directement sous Linux avec le spooler lpd, donc pour imprimer comme d'habitude :

lpr (-P imprimante) monfichier.*

(ce qui est entre parenthèses étant optionnel.)

Conclusion

Malheureusement certaines "qualités" de certaines imprimantes de sont pas encore supportées : "Duplex printing is not supported", pour les séries 9xx, mais en allant régulièrement sur http://hpinkjet.sourceforge.net, vous verrez les dernières améliorations.

Je rappelle aussi que quelques imprimantes Epson et Canon peuvent elle aussi être optimisées avec les outils xw_tools ; bien qu'ils permettent parfois une impression jusqu'à 1440 dpi rien n'est assuré pour les imprimantes de la gamme HP, c'est pourquoi il vaut mieux utiliser les drivers de HP.
Remarque : bien que ceux-ci soient sous une license Open-source, il est vrai qu'ils ne sont pas libres, du moins pas sous les termes de la license GPL/LGP.

Liens xw_tools :

Note : la compilation des drivers HP ne marche pas sous RootLinux 1.2 chez moi.




@ Retour à la rubrique Matériel

(c) 2001 BRARD Emmanuel, emman@agat.net
Ce document est sous license GNU FDL .

Cette page est issue de la documentation 'pré-wiki' de Léa a été convertie avec HTML::WikiConverter. Elle fut créée par BRARD Emmanuel le 28/08/2001.

Copyright

Copyright © 28/08/2001, BRARD Emmanuel

Tête de GNU Vous avez l'autorisation de copier, distribuer et/ou modifier ce document suivant les termes de la GNU Free Documentation License, Version 1.2 ou n'importe quelle version ultérieure publiée par la Free Software Foundation; sans section invariante, sans page de garde, sans entête et sans page finale. Pour plus d'informations consulter le site de l'APRIL.
Affichages

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons CC-BY-SA