Léa-Linux & amis :   LinuxFR   GCU-Squad   Zarb.Org   GNU
Acheter du matériel compatible
Cle-anglaise.png Attention ! Cet article est en cours de rédaction. Il n'a donc encore été ni relu, ni corrigé, ni validé par un modérateur.
Léa vous encourage à éditer les articles pour les améliorer ou les corriger.

Sommaire

[modifier] Problématique

Vous êtes maintenant passé à Linux. Votre matériel actuel est plus ou moins bien reconnu, vous avez eu un certain nombre de problèmes (par exemple : imprimante multifonction dont une partie seulement des possibilités est utilisable sous Linux). Votre prochain achat, c'est sûr, sera un matériel parfaitement reconnu et facile à configurer.

Bonne idée ! Mais comment faire ?

[modifier] Distribution

Ça dépend beaucoup de votre distribution, par exemple :

Je sais ... toutes les distributions n'ont pas été citée : c'est fait exprès !

De plus, si votre matériel n'est pas supporté par votre distribution, mais que le driver existe, vous pouvez - si vous vous en sentez le courage - l'installer manuellement. C'est un cas rare, mais qui peut arriver.

Afin de savoir si votre matériel est supporté, allez lire les bases de données qui sont sur internet :

[modifier] Quel type de matériel

[modifier] Interne

[modifier] Un processeur

Aucun problème, Linux est compatible avec pratiquement tous les processeurs !

Par contre les distributions ne le sont en général pas ! Il faut donc vérifier que la distribution que vous comptez utiliser est disponible dans une version compatible avec votre processeur.

Les processeurs grand public de type x86 qu'on trouve sur les PC (AMD, Intel...) sont tous compatibles, et toutes les distributions ou presque ont une version pour eux.

Si vous utilisez Linux sur une machine Power PC (un Apple d'avant leur passage à Intel), sachez que les logiciels privateurs (par exemple les drivers Nvidia ou ATI, ou encore Skype) ne seront en général pas disponibles pour votre machine. Encore un avantage du libre sur le propriétaire ! Dans ce cas, vous devez bien sûr utiliser une distribution spéciale "ppc" (j'ai installé une Kubuntu PPC sur un vieil Imac, cela fonctionne comme un charme, et remplace avec bonheur Mac OS 9).

[modifier] Une carte mère

Peu de problème avec les cartes mères en général, attention toutes fois à vous renseignez un peu sur les forums si la carte que vous vous apprêtez à acheter ne souffre pas de bugs en particulier dans l'ACPI.

La matériel supplémentaire embarqué peut parfois poser des problèmes :

  • contrôleur RAID (en général bien supportés, sauf ceux qui viennent de sortir)
  • carte réseau intégrées (en général bien supportées)
  • cartes son intégrées : ce sont elles qui sont l'une des plus grandes causes d'incompatibilité des cartes mères.

[modifier] Une carte graphique

Si vous changez de carte graphique, ce n'est certainement pas pour n'utiliser qu'une seule partie de ses capacités ! Pour cela, deux choix s'offrent à vous :

[modifier] drivers libres

  • NVidia : A l'heure actuelle, aucune carte NVidia ne dispose de drivers libres gérant correctement la 3D. A surveillez, un driver libre en développement : http://nouveau.freedesktop.org/wiki/
  • ATI/AMD : A l'heure actuelle, AMD diffuse les spécifications 2D/3D de ses cartes graphiques, mais toutes ne sont pas correctement supportées au niveau de la 3D.
    • les cartes à base de Radeon, Rage 128, Rage pro, Mach64, autre plus ancien sont supportée par le driver ati (aucune chance que vous achetiez une des ces cartes) : elles ont un support 3D au niveau de leurs performances : insuffisant
    • les cartes à base de r1xx à r4xx (pas récentes quoi : il y a fort peut de chance que vous achetiez une des ses cartes) sont supportées par le driver radeon : assez bon support de la 3D
    • les cartes plus récentes à base de r5xx, rv5xx à r5xx, rv6xx, ainsi que M5x à M7x (en gros : les Radeon HD) sont supportées par le driver radeonhd, avec aucun support de la 3D (pour l'instant...)
  • Intel : dans l'ensemble un assez bon support (voir : http://intellinuxgraphics.org/user.html ) permettant en particulier d'utiliser assez confortablement le compositing (ie: Compiz/Beryl et autres Wobbleries)
  • Via : assez bien supporté (voir : http://unichrome.sourceforge.net ) mais à éviter pour faire de la 3D

[modifier] drivers propriétaires

  • NVidia : bon driver pour les cartes récentes, les cartes très anciennes ne sont plus supportées (TNT, TNT2 entre autre)
  • ATI : driver qui supporte pratiquement toutes leurs cartes en particulier pour la 3D (ce qui manque au driver radeonhd, mais pour combien de temps ...)

[modifier] Cartes PCI/PCI Express/AGP

  • les cartes ajoutant des choses classiques (usb, firewire, scsi, sata, etc ...) sont bien supportées,
  • les autres : à vérifier soigneusement, en particulier là : http://www.tldp.org/HOWTO/Hardware-HOWTO

[modifier] Cartes Sons

Consultez la listes des cartes compatibles (ou pas) :

A priori, si votre carte son est compatible ALSA et OSS alors choisissez ALSA.

[modifier] Disque (P)ATA/SATA

Qu'il s'agisse de disques durs ou de lecteurs/graveurs de cd/dvd : ils sont tous reconnus.

[modifier] Lecteur de Disquette

Quelqu'un compte encore acheter une chose pareille ? De toutes façon, ils sont tous supportés.

[modifier] Lecteur de Cartes n en 1

Les lecteurs de cartes usb sont tous supportés, pour les autres : évitez les !

[modifier] Ecran LCD/VFD intégré au boîtier

Les écrans SoundGraph iMon ( http://venky.ws/projects/imon/ ) sont supportés. Il faut noter que ces écrans sont souvent ceux qui équipent les boîtiers HTPC.

Pour les autres consultez : http://lcdproc.org/hardware.php3

[modifier] Externe

[modifier] Imprimante

LA source DU savoir est là : http://www.openprinting.org/printer_list.cgi

Pour les HP, vous pouvez aussi allez voir là : http://hplip.sourceforge.net/supported_devices/index.html

Mais surtout : évitez d'acheter certaines marques comme Canon qui sont très mal supportées (par leur faute : ils refuses de livrer les spécifiacations).

[modifier] Modems

[modifier] Modems téléphoniques (RTC)

Pour ceux qui n'ont pas encore le haut débit, les modems sur port série sont tous supportés. Les modems sur port USB disposent aussi d'un support, mais n'ayant jamais testé je ne peux pas vour dire s'ils sont tous supportés. Les modems internes aussi, tant que ce ne sont pas des winmodems. Cependant, il y a pas mal de drivers pour ces derniers, vérifiez sur le net.

[modifier] Modems haut débit

Les modems haut débit connectés en Ethernet n'ont aucun problème, puisque c'est la carte réseau qui fonctionne sous Linux. Si votre modem propose USB et Ethernet, préférez donc Ethernet. Si vous êtes obligés d'utiliser un modem USB, regardez sur internet : il est probable que quelqu'un aura développé un driver.

[modifier] Périphérique USB

Une bonne liste est là : http://www.qbik.ch/usb/devices/search.php

Mais ce qu'il faut ce rappeler avec les périphériques usb c'est que ce qui compte, ce n'est pas le nom qui est écrit sur la boîte, mais les identifiants USB qui sont obtenus uniquement lorsqu'on a acheté le périphérique avec la commande : lsusb ! En effet, il est très courant que des constructeurs (Creative, Hauppauge, etc ...) donnent le même nom à des périphériques techniquement différents... comme ça : on sait bien ce qu'on achète !

Note : pour tous les appareils susceptibles de stocker des données que vous désirez transférer, préférez ceux qui supportent le protocole "stockage de masse" (mass storage ou usb-storage), car ils seront plus faciles à utiliser. Un autre protocole existe, nommé MTP (multimedia transfer protocol). Ce protocole est supporté sous Linux, mais nécessite en général des logiciels spécifiques (comme Gphoto2 pour les appareils photo), alors que le stockage de masse est accessible directement dans le système de fichiers. Il est possible de monter un appareil MTP dans le système de fichiers avec gphotofs ou mtpfs, mais je ne sais pas si c'est automatisé sur toutes les distributions.

[modifier] WebCAM

Plus spécifiquement pour les webcams, il y a les sites des drivers :

Note : à noter que certaines webcams fonctionnent très bien sous Linux, mais produisent un flux video non compatible avec Skype (sous Windows, la conversion entre les formats est faite dans le driver). Par exemple ma Philips SPC1000, supportée par le driver UVC ne fonctionne pas avec Skype car elle produit uniquement un flux MJPEG et Skype veut du YUY2.

[modifier] Clé USB

Les clés USB qui respectent la norme (à ma connaissance : toutes) usb-storage sont supportées.

Il en va de même pour les disques durs externes USB, les adaptateurs pour cartes mémoire (SD, micro SD, compact flash, XD...). En bref, tout ce qui permet de stocker des données.

[modifier] Clé Bluetooth

A priori toutes les clefs Bluetooth sont supportées, j'ai une noname à 10€ qui fonctionne parfaitement.

[modifier] Baladeur

Préférez un baladeur capable de lire des formats ouverts (Ogg ou Flac). Vous en trouverez une liste là : http://wiki.xiph.org/index.php/VorbisHardware. De plus il est plus simple à utiliser sous Linux s'il permet de se connecter en protocole usb-storage, bien que le protocole MTP soit aujourd'hui bien supporté.

[modifier] Appareil photo

Préférez les appareils photo qui permettent de se connecter en protocole usb-storage, cela en simplifiera grandement l'utilisation.

Ceux qui utilisent le protocole MTP, Gphoto2 permettra d'accéder à leur appareil.

[modifier] Téléphone mobile

Les téléphones ont souvent des protocoles très propriétaires, aussi si vous pouvez acheter un téléphone connectable en usb-storage, c'est le top !

[modifier] Scanner

Sous Linux, les drivers de scanners utilisent l'API SANE (Scanner Access Now Easy), le projet maintient une liste de scanner supportés : http://www.sane-project.org/sane-mfgs.html .

Il existe aussi des imprimantes tout en un (qui ont donc un scanner à plat), en particulier chez HP qui maintient une liste de matériels supportés : http://hplip.sourceforge.net/supported_devices/index.html (vérifiez bien que la partie scanner est supportée)

Affichages
Outils personnels

Serveur hébergé par ST-Hebergement et Lost-Oasis / IRC hébergé par FreeNode / NS secondaire hébergé par XName
Sauf mention contraire, les documentations publiées sont sous licence Creative-Commons CC-BY-SA